Heads up for anybody using CreateMist in 4RPL scripts

Argonwolf · 358

Argonwolf

  • Jr. Member
  • **
    • Posts: 68
If you set the "direction" vector to zero (V3(0 0 0)) the game will hang (at least it does on my computer), so if you don't want to set a start velocity just omit the direction field altogether. I'm giving this heads-up because if you haven't saved recently you might lose stuff you were working on. This only seems to occur when all three axes are set to zero, so for example V3(0 1 0) isn't a problem.



Karsten75

  • Hero Member
  • *****
    • Posts: 7117
Reply #1 on: May 25, 2021, 07:35:14 am
You should open an issue on GitHub and provide the player.log file. Seems like you uncovered a bug.

https://github.com/KnuckleCracker/CW4-bug-tracker/issues

'If you want to live a happy life, tie it to a goal, not to people or things.'

Albert Einstein
(1879-1955)


Argonwolf

  • Jr. Member
  • **
    • Posts: 68
Reply #2 on: May 26, 2021, 03:50:50 pm
The log file doesn't show anything abnormal, the game hangs as if stuck in an infinite loop but closes promptly when force-quit. That being said, I narrowed it down to only ever happening when the "direction" field is set to V3(0 0 0), so hopefully that makes it easier to find (I first thought maybe something was being divided by the vector's magnitude creating a divide-by-zero error).

As for the GitHub report, I can't justify making an entire new website account just for this, hence why I just posted it as a warning to coders instead of a bug report. If I somehow start finding bugs frequently then I'll reconsider getting on GitHub.



knucracker

  • Administrator
  • *****
    • Posts: 11780
Reply #3 on: May 27, 2021, 01:56:21 pm