The Map Editor is Seriously Janky

Started by Zoura3025, December 06, 2020, 04:41:06 PM

Previous topic - Next topic


So, I bought this game on launch day, but have only recently (in the past day) have jumped into the map creator, and holy cow have I found a lot of problems. I'm not putting this as a formal bug report because I'm on windows 8, and the log files are only suported on windows 10.

How I Feel About the Map Editor

I gotta be honest... In my opinion, this is the worst map editor since Creeper World 2's, at least by layout. Bugs outstanding, the layout feels really poor compared to Creeper World 3's or Particle Fleet's; where in those games, you had rellatively minimalistic designs smoothly laid out across the bottom or side of the screen (respectively), Creeper World 4's just feels claustrophobic being crammed into the corner. Also unlike creeper world 3's editor, the normal clutter of the HUD isn't stripped back when go into the editor, and it just makes it feel really restrictive when I'm trying to do anything.

I don't have any comments on 4RPL yet, just because there's no easily available reference and I haven't gotten into coding for it yet, but the functionality looks different than creeper world 3 for sure.

I do want to bring up that I don't hate the map editor; it's usable, and I even got a good way though making a map (before it crashed my computer; see below) , but it just feels like a massive step down after the (in my humble opinion) masterful execution of the Creeper World 3 and Particle Fleet editors.

Crashes to Crashes, Dust to Dust

I've had the game crash twice while using the editor, and I can't quite find rhymes or reasons why.

The first crash happened when I tried to click the "Import CPACK" button (I was just playing and trying to figure out what everything was does). After I rebooted, I discovered that this crash had corrupted the world and made quite the mess of the editor menu, turning it into an almost dartlike shape with no functionality aside from blocking part of the screen (see attached screenshot). I have since tried to repeat the crash, and nothing's gone wrong. So, the game might just be having a case of "trying to figure out file paths" syndrome.

The second crash was a complete computer crash that forced my PC to reboot. I'd think it's my computer's fault, but this crash only happened through the editor (I've beaten the whole compaign with exception of the last mission without issue), so I'm thinking it's a fault in the editor itself. I don't know how to repeat this crash, but if more spontaneous crashes keep happening, I'll be sure to post updates.

I would like to say, however, my laptop is pretty old (5-ish years), and I've updated the drivers as far as they'll go. I might just need newer hardware. The game runs just fine, though, so I'm not sure how hardware-heavy the problem is.
(09:06:07) Zoura3025: But for us diehard fans: "Time is Sanity"