Pink screen of death

FlyingGeese · 559

FlyingGeese

  • Newbie
  • *
    • Posts: 2
on: October 13, 2019, 12:59:55 pm
I hope I posted in the correct board.

Played CW3 in 2018, worked perfectly, stopped awhile. Picked it up last month, got the pink screen in the Main Menu. Have both discrete and integrated cards, googled for answers. Tried the following but didnt work:-
a) Force game to use Nvidia
b) Change nvidia settings to maximum power
c) Force game to use directx 9 via Steam's Properties
d) Verify game files

I dont think I have updated the drivers since 2018, not sure what went wrong. Here's the output log.




Builder17

  • Community Guild
  • *****
    • Posts: 1072
  • My account picture is from Nitrome Mutiny.
Reply #1 on: October 14, 2019, 05:09:59 am
https://knucklecracker.com/forums/index.php?topic=22132.msg151670#msg151670

Quote
I opened Device Manager and disabled the NVidia GPU.  That fixed it - game is playable.  Unfortunately, it's not stable.  CW2 wasn't stable either...but I finished the game quick enough to be a problem.

This maybe works, but I don't promise anything.
« Last Edit: October 14, 2019, 05:13:37 am by Builder17 »



FlyingGeese

  • Newbie
  • *
    • Posts: 2
Reply #2 on: October 14, 2019, 07:25:42 am
I forced CW3 to use the Intel Integrated Card via the Nvidia Gui, didnt work earlier. Lemme try via Windows.



GoodMorning

  • Community Guild
  • *****
    • Posts: 3383
  • (Pusillanimous)
Reply #3 on: October 14, 2019, 07:32:28 am
The following lines in the log look possibly-relevant:

Code: [Select]
Forcing GfxDevice: Direct3D 9
...
d3d: failed to create device [queried technique not available]

However, I am by no means an expert - it's just as possible from what I know that you have a driver mismatch that an update may resolve.

A narrative is a lightly-marked path to another reality.


Karsten75

  • Hero Member
  • *****
    • Posts: 6826
Reply #4 on: October 14, 2019, 08:16:50 am
Pink/magenta squares instead of images rendered is a well-known indicator of issues with your graphics support.  Usually means either the device is failing or your drivers are at issue. There isn't anything specifically we can do to help you unfortunately.

I looked at the log file and the one thing that seems ultra-weird is that the game initialized both the Intel and Nvidia graphics. - tis should not happen. THen it also complained that there were no shaders - again, points to best case drivers, worst case hardware.

If you are using command-line overrides, as suggested by the
Forcing GfxDevice: Direct3D 9
line, I'd suggest you remove those.

For now, the game should at least run with either your intel or Nvidia graphics, but not both. :)

I would suggest you remove all settings that directs the game/operating system/hardware/ to prefer one GPU over the other, download graphics drivers for both Nvidia and the Intel GPUs and then test again and see where you're at.

If you play any other games that rely on GPU rendering, I'd be interested to hear whether they're working or not.

"Any leftover cabbage can and will be mixed with mayo"
   - Cole's Law