Author Topic: game starts in very small window and cant resize it  (Read 959 times)

wvdburgt

  • Jr. Member
  • **
  • Posts: 9
game starts in very small window and cant resize it
« on: January 28, 2019, 06:34:31 pm »
Hello,

A while i go i bought this awesome game and i played quite often. since a month or so i got a new computer and downloaded the game again today because i feel like it.
But somehow it wont start. Before i had an ATI card, now Nvidia.  I have the exact same screens as before. the resolution is 1920x 1080 so nothing strange there either.

My setup:
Nvidia 2080TI
i7 8700K
32 GB
the latest Windows 10 (10.0.17763)

Yes its a bit overkill for this game:P


I tried disable screen scaling in the driver but that didnt help. I also tried the following compatibility options: run this game in compatbility mode for windows 8 and disable full screen optimalisations. None seem to work.

I have attached a screenshot of how it runs and the error and also dxdiag. Looking forward to play this game again:)

knucracker

  • Administrator
  • *****
  • Posts: 11745
Re: game starts in very small window and cant resize it
« Reply #1 on: January 29, 2019, 08:22:37 am »
If you get the game to launch, but it is in a small window, can you resize the window (just drag the corner or edge)?

The games stores its startup size and mode in this file:
c:\Users\YOUR_USER\AppData\Roaming\creeperworld3\GameSettings.xml  (note that AppData may be hidden)
You can temporarily rename that file (while the game is not running) then try starting it up to see what happens.

Karsten75

  • Hero Member
  • *****
  • Posts: 6777
Re: game starts in very small window and cant resize it
« Reply #2 on: January 29, 2019, 09:55:31 am »
Also, look for the output log from the game and attach it here - it may have a few more details of relevance.

Directions to find the log file: https://knucklecracker.com/forums/index.php?topic=16476.0
"Any leftover cabbage can and will be mixed with mayo"
   - Cole's Law

wvdburgt

  • Jr. Member
  • **
  • Posts: 9
Re: game starts in very small window and cant resize it
« Reply #3 on: January 29, 2019, 03:51:49 pm »
Also, look for the output log from the game and attach it here - it may have a few more details of relevance.

Directions to find the log file: https://knucklecracker.com/forums/index.php?topic=16476.0
If i resize i get the error shown. I modified the file like this:
  <WindowWidth>1280</WindowWidth>
  <WindowHeight>1024</WindowHeight>
but this crashes the game immidiatly with that error.
i also attached the file requested.
« Last Edit: January 29, 2019, 03:55:23 pm by wvdburgt »

Karsten75

  • Hero Member
  • *****
  • Posts: 6777
Re: game starts in very small window and cant resize it
« Reply #4 on: January 29, 2019, 06:18:21 pm »
Seems KC is not in right now

Please try this.

- Turn off Steam cloud saving so the files aren't synchronized from the Cloud.
- **delete** gamesettings. xml file - Don't just change values in it.
 - make sure the AMD drivers are uninstalled.

Reboot your system, so things get cleaned up.

Try the game again.

I think it may be something in the way Unity is trying to handle the 3 monitors it sees  in your setup.
"Any leftover cabbage can and will be mixed with mayo"
   - Cole's Law

wvdburgt

  • Jr. Member
  • **
  • Posts: 9
Re: game starts in very small window and cant resize it
« Reply #5 on: January 29, 2019, 06:39:13 pm »
Seems KC is not in right now

Please try this.

- Turn off Steam cloud saving so the files aren't synchronized from the Cloud.
- **delete** gamesettings. xml file - Don't just change values in it.
 - make sure the AMD drivers are uninstalled.

Reboot your system, so things get cleaned up.

Try the game again.

I think it may be something in the way Unity is trying to handle the 3 monitors it sees  in your setup.

Thank you for your comment. I have indeed 3 screens and i used AMD before switching to Nvidia. I have deleted the gamesettings and stopped the cloud sync. I even reinstalled the game and rechecked the cloud options but still the same. As soon as i resize it i get the error. I also tried disconnecting the other 2 screens using the windows option to see if that helps but that didnt help either.

knucracker

  • Administrator
  • *****
  • Posts: 11745
Re: game starts in very small window and cant resize it
« Reply #6 on: January 29, 2019, 07:58:50 pm »
Lets get a little more info if we can.  Try these things and see if any makes a difference

1: Disable the steam overlay and try everything again. It's a long shot, but an easy one to try.

2: Switch to version 208 of Creeper World 3 in steam.  Right click the game in the steam client, then go to properties and the Beta tab.  You'll find version 208 there.  It is the same game just built with a different version of the Unity game engine.  If you run 208 and it has the same problem, collect the game's log file immediately after the crash and post it back here.

3: There are some command line options you can try to see if any of them shake anything loose.  They are here https://docs.unity3d.com/Manual/CommandLineArguments.html . Scroll down to the "Unity Standalone Player command line arguments" section.  There are command line arguments there for full screen, window width, height, etc.  You should be able to set them by right clicking the game in the steam client and choosing Launch options.

4: If nothing works, try clicking on the settings world on the main menu of the game (I know it's small).  From there you will get the settings screen.  See if you can view the list of resolutions that the game thinks it can see.  See attached screenshot for an example

« Last Edit: January 29, 2019, 08:01:17 pm by knucracker »

Karsten75

  • Hero Member
  • *****
  • Posts: 6777
Re: game starts in very small window and cant resize it
« Reply #7 on: January 30, 2019, 09:54:00 am »
In the event that the above doesn't work, I've been Googling for similar issues with Unity and steam games. 

Here are some of the actions that has been suggested by developers and players:

Quote
Set Launch Options

-Right-click on the game title under the Library in Steam and select Properties.

-Under the General tab click the Set launch options... button.

-Enter the launch options you wish to apply (be sure to separate each code with a space) and click OK.

IN THIS CASE HERE USE THIS: -fullscreen it will force the game to be launched in fullscreen

-Close the game's Properties window and launch the game.

Quote
CTRL-Click on the play button in the library and choose your resolution, windowed/fullscreen options and try that.

Quote
Try holding ALT when you click to launch the game. You should be able to select the resolution and turn off the Windowed mode.

Quote
1) open windows explorer
2) search for SteamLauncher
3) right click the file
4) goto compatibility tab
5) Check mark "Override high DPI scaling behavior.Scaling performed by: change to system".
6) Shut down steam completely, restart game

Quote
F11 in the game window


Be very careful with the following: I adjusted it from a different game, and have not tested it!

Quote
Open up regedit.exe from the run window (Windows Key + R)
navigate to this key:
HKEY_CURRENT_USER\SOFTWARE\HKEY_CURRENT_USER\Software\Knuckle Cracker LLC\HKEY_CURRENT_USER\Software\Knuckle Cracker LLC\Creeper World 3

There are 3 entries you need to change:
Screenmanager Is Fullscreen mode_h********** : this is whether or not fullscreen is enabled 1=yes, 0=no
Screenmanager Resolution Height_h********** : this is pretty self explanatory if you use a 1080p monitor, this one should be 1080
Screenmanager Resolution Width_h********** : same, a 1080p monitor has this one as 1920
* = random number, don't worry about it.

Double click on the numbers you want to change, change the number to what it should be, leave it as Hexadecimal (Don't worry, your decimal numbers will convert automatically) and then press OK button.



I can search more, but you get my drift... ;)
"Any leftover cabbage can and will be mixed with mayo"
   - Cole's Law

wvdburgt

  • Jr. Member
  • **
  • Posts: 9
Re: game starts in very small window and cant resize it
« Reply #8 on: January 30, 2019, 04:01:41 pm »
Lets get a little more info if we can.  Try these things and see if any makes a difference

1: Disable the steam overlay and try everything again. It's a long shot, but an easy one to try.

2: Switch to version 208 of Creeper World 3 in steam.  Right click the game in the steam client, then go to properties and the Beta tab.  You'll find version 208 there.  It is the same game just built with a different version of the Unity game engine.  If you run 208 and it has the same problem, collect the game's log file immediately after the crash and post it back here.

3: There are some command line options you can try to see if any of them shake anything loose.  They are here https://docs.unity3d.com/Manual/CommandLineArguments.html . Scroll down to the "Unity Standalone Player command line arguments" section.  There are command line arguments there for full screen, window width, height, etc.  You should be able to set them by right clicking the game in the steam client and choosing Launch options.

4: If nothing works, try clicking on the settings world on the main menu of the game (I know it's small).  From there you will get the settings screen.  See if you can view the list of resolutions that the game thinks it can see.  See attached screenshot for an example

1. disabled: no effect. i also disabled the Geforce experience overlay. also no effect.
2. version 208: diference is that it now immidiatly comes with the error. not after resize
3. in 208: same results as before. in the old version i can get it to work in a higher resolution with the with and hight options but 1280x720 seems to be the highest i can get. the full screen option doesnt seem to work
4. i do see the options but if i choose an option it crashes.


answer for the solutions that Karsten75 gave:
- the options are as described by the Unity article: same results: i get the game working @ maximum 1280x720.
- ctrl click: doesnt seem to work. i dont get an extra window. with our without the fullscreen option
- alt: same story
- change DPI settings to system for both steam and CW3: doesnt seem to effect the game. it did made my computer slow then and then crash so disabled this again.
- register edit: changed fullscreen from 0 to 1--> game crash.


Karsten75

  • Hero Member
  • *****
  • Posts: 6777
Re: game starts in very small window and cant resize it
« Reply #9 on: February 06, 2019, 06:41:17 pm »
No not yet. I replied with the findings in the other post. It works @ 1280x720 but with a bit of fps drops

How did you get it to work at that resolution? once you cleared the hurdle of the impossible small window, I'd have imagined you could even drag the window to the required size?

You could try deleting that registry key - the entire ..\Knuckle Cracker LLC\Creeper World 3\ key

Unity should put it back. Or you could copy it out before deleting it to be extra-safe. I would also advise you investigate altering the values in the Height/width keys perhaps.
"Any leftover cabbage can and will be mixed with mayo"
   - Cole's Law

wvdburgt

  • Jr. Member
  • **
  • Posts: 9
Re: game starts in very small window and cant resize it
« Reply #10 on: February 07, 2019, 06:39:20 pm »
i got it working using the unity -height and -with options to start it. Thats the only way i got it working atm. As soon as i resize it, it fails again.

wvdburgt

  • Jr. Member
  • **
  • Posts: 9
Re: game starts in very small window and cant resize it
« Reply #11 on: February 18, 2019, 04:02:03 pm »
would still like to play it with a bigger resolution then 1280x768:D

knucracker

  • Administrator
  • *****
  • Posts: 11745
Re: game starts in very small window and cant resize it
« Reply #12 on: February 20, 2019, 07:54:23 am »
You've exhausted about everything I can think of.  I still wonder if there is some leftover unity registry setting or something like that which is causing the issue.  The only other thing I could think of would be to try running the game in a sandbox.  If you have windows 10 pro, you can try that (if you have home, microsoft has deemed sandboxing a no-go... which is really unfortunate).

wvdburgt

  • Jr. Member
  • **
  • Posts: 9
Re: game starts in very small window and cant resize it
« Reply #13 on: February 20, 2019, 06:29:39 pm »
I found a solution! Turns out : msi afterburner together with rivaturner statistics server. If i close those everything is fine!

Karsten75

  • Hero Member
  • *****
  • Posts: 6777
Re: game starts in very small window and cant resize it
« Reply #14 on: February 20, 2019, 09:59:35 pm »
\_(ツ)_/
"Any leftover cabbage can and will be mixed with mayo"
   - Cole's Law