Issue with Mac version-CW3

environerd · 1609

environerd

  • Jr. Member
  • **
    • Posts: 6
on: November 05, 2018, 01:42:48 am
Can anyone help me figure out what is happening? When I launch CW3 The cracking Knuckle sound plays but nothing else happens. no visuals at all. I can open it to full screen but it's just a blank black screen. I looked at other threads and checked the log and this is what I get:

Unloading 10 unused Assets to reduce memory usage. Loaded Objects now: 6368.
Total: 2.519552 ms (FindLiveObjects: 0.306603 ms CreateObjectMapping: 0.151894 ms MarkObjects: 2.023900 ms  DeleteObjects: 0.036844 ms)

Platform assembly: /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/Mono.Security.dll (this message is harmless)
ERROR building certificate chain: System.ArgumentException: certificate ---> System.Security.Cryptography.CryptographicException: Unsupported hash algorithm: 1.2.840.113549.1.1.12
  at Mono.Security.X509.X509Certificate.VerifySignature (System.Security.Cryptography.RSA rsa) [0x00000] in <filename unknown>:0
  at Mono.Security.X509.X509Certificate.VerifySignature (System.Security.Cryptography.AsymmetricAlgorithm aa) [0x00000] in <filename unknown>:0
  at System.Security.Cryptography.X509Certificates.X509Chain.IsSignedWith (System.Security.Cryptography.X509Certificates.X509Certificate2 signed,
System.Security.Cryptography.AsymmetricAlgorithm pubkey) [0x00000] in <filename unknown>:0
  at System.Security.Cryptography.X509Certificates.X509Chain.Process (Int32 n) [0x00000] in <filename unknown>:0
  at System.Security.Cryptography.X509Certificates.X509Chain.ValidateChain (X509ChainStatusFlags flag) [0x00000] in <filename unknown>:0
  at System.Security.Cryptography.X509Certificates.X509Chain.Build (System.Security.Cryptography.X509Certificates.X509Certificate2 certificate) [0x00000] in <filename unknown>:0
  --- End of inner exception stack trace ---
  at System.Security.Cryptography.X509Certificates.X509Chain.Build (System.Security.Cryptography.X509Certificates.X509Certificate2 certificate) [0x00000] in <filename unknown>:0
  at System.Net.ServicePointManager+ChainValidationHelper.ValidateChain (Mono.Security.X509.X509CertificateCollection certs) [0x00000] in <filename unknown>:0
Please, report this problem to the Mono team

News: Join the Knuckle Cracker Discord Chat! -> |u=https://discord.gg/knucklecracker Open_Web_Page
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

Any help is much appreciated. Thanks.



Karsten75

  • Hero Member
  • *****
    • Posts: 6833
Reply #1 on: November 05, 2018, 02:07:09 am
Did you download from Steam? Or where did you get the game from? Can you try to remove the game and re-download? Also, most times rebooting your computer solves a number of problems.

Try that and if no help, post back. Virgil should be back in the morning and may have further ideas.

"Any leftover cabbage can and will be mixed with mayo"
   - Cole's Law


environerd

  • Jr. Member
  • **
    • Posts: 6
Reply #2 on: November 05, 2018, 04:23:49 am
Downloaded straight from Knuckle Cracker. I'd prefer not to delete and re-download because I've done that before and I lose progress and have to start over. I tried re-booting and it does the same. I've re-downloaded the most updated version, but no change. Thanks for the suggestions, but nothing yet. Hopefully Virgil or someone else can help. :)



knucracker

  • Administrator
  • *****
    • Posts: 11750
Reply #3 on: November 05, 2018, 08:35:55 am
What version of MacOS are you running.  Also, attach or send me the whole log file.  Could be there is something different going on and the cert exception is a red herring.  Also, it sounds like the game might have been working for you and then stopped.  Did anything of note change since you last ran the game (update the OS, networking change, a hard crash of the OS, etc.)

The other things you can immediately try are:
- Here is version 208.  It's the same as 212 just built with a different version of Unity. Give it a shot and see if the results are different:
http://knucklecracker.com/creeperworld3/dd_webb/CreeperWorld3-208-OSX.zip

- If you have multiple monitors, try with just a single monitor.  That isn't the permanent solution, but if it works with 1 monitor, that narrows down the problem.

Note that you can remove the app or use a different version of the game (from above) and not lose your progress.  Your progress is stored in the directory indicated in this post: http://knucklecracker.com/forums/index.php?topic=17997.0

You can also backup that directory before messing with anything in case you worry about losing your progress.



environerd

  • Jr. Member
  • **
    • Posts: 6
Reply #4 on: November 05, 2018, 10:43:59 pm
MacOSX High Sierra 10.13.6, Full log below. I can't think of any major changes, other than a wifi issue, but I don't think that would affect it. Still no luck with one display and the version you sent. I appreciate the help.





Initialize engine version: 5.2.3f1 (f3d16a1fa2dd)
GfxDevice: creating device client; threaded=1
OpenGL:
    Version:  OpenGL 2.1 [2.1 ATI-1.68.20]
    Renderer: AMD Radeon Pro 555 OpenGL Engine
    Vendor:   ATI Technologies Inc.
    VRAM:     2048 MB
    Extensions: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_blend_equation_separate GL_ATI_blend_weighted_minmax GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_barrier GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod
GL: buggy packed depth stencil; Deferred rendering will use slower rendering path
GL: Detected 2048 MB VRAM
Begin MonoManager ReloadAssembly
Platform assembly: /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/UnityEngine.dll (this message is harmless)
Loading /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/UnityEngine.dll into Unity Child Domain
Platform assembly: /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/Assembly-CSharp-firstpass.dll (this message is harmless)
Loading /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/Assembly-CSharp-firstpass.dll into Unity Child Domain
Platform assembly: /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/Assembly-CSharp.dll (this message is harmless)
Loading /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/Assembly-CSharp.dll into Unity Child Domain
Platform assembly: /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/Assembly-UnityScript-firstpass.dll (this message is harmless)
Loading /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/Assembly-UnityScript-firstpass.dll into Unity Child Domain
Platform assembly: /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/Assembly-UnityScript.dll (this message is harmless)
Loading /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/Assembly-UnityScript.dll into Unity Child Domain
Platform assembly: /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/UnityEngine.UI.dll (this message is harmless)
Loading /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/UnityEngine.UI.dll into Unity Child Domain
Platform assembly: /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/UnityEngine.Networking.dll (this message is harmless)
Loading /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/UnityEngine.Networking.dll into Unity Child Domain
Platform assembly: /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/System.Core.dll (this message is harmless)
- Completed reload, in  0.033 seconds
Platform assembly: /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/System.dll (this message is harmless)
Platform assembly: /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/System.Xml.dll (this message is harmless)
Platform assembly: /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/UnityScript.Lang.dll (this message is harmless)
Platform assembly: /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/Boo.Lang.dll (this message is harmless)
Platform assembly: /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/System.Xml.Linq.dll (this message is harmless)
Setting up 2 worker threads for Enlighten.
  Thread -> id: 70000c6f5000 -> priority: 1
  Thread -> id: 70000c778000 -> priority: 1
Unloading 3 Unused Serialized files (Serialized files now loaded: 0)
UnloadTime: 0.416652 ms
Using base settings dir: /Users/ianries/.config/creeperworld3/
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

Using base game data dir: /Users/ianries/Documents/creeperworld3/
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

Shader Quality: 30
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

Quality: 0
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

Game Version: 2.12
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

Checking for Update...
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

Checking for News...
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)


Unloading 10 unused Assets to reduce memory usage. Loaded Objects now: 6368.
Total: 2.519552 ms (FindLiveObjects: 0.306603 ms CreateObjectMapping: 0.151894 ms MarkObjects: 2.023900 ms  DeleteObjects: 0.036844 ms)

Platform assembly: /private/var/folders/9r/hrlbb7jn79dfkvp46t22ftkr0000gn/T/AppTranslocation/5AD5DF4B-7079-4C77-9FC9-2270888ACBF7/d/CW3.app/Contents/Resources/Data/Managed/Mono.Security.dll (this message is harmless)
ERROR building certificate chain: System.ArgumentException: certificate ---> System.Security.Cryptography.CryptographicException: Unsupported hash algorithm: 1.2.840.113549.1.1.12
  at Mono.Security.X509.X509Certificate.VerifySignature (System.Security.Cryptography.RSA rsa) [0x00000] in <filename unknown>:0
  at Mono.Security.X509.X509Certificate.VerifySignature (System.Security.Cryptography.AsymmetricAlgorithm aa) [0x00000] in <filename unknown>:0
  at System.Security.Cryptography.X509Certificates.X509Chain.IsSignedWith (System.Security.Cryptography.X509Certificates.X509Certificate2 signed, System.Security.Cryptography.AsymmetricAlgorithm pubkey) [0x00000] in <filename unknown>:0
  at System.Security.Cryptography.X509Certificates.X509Chain.Process (Int32 n) [0x00000] in <filename unknown>:0
  at System.Security.Cryptography.X509Certificates.X509Chain.ValidateChain (X509ChainStatusFlags flag) [0x00000] in <filename unknown>:0
  at System.Security.Cryptography.X509Certificates.X509Chain.Build (System.Security.Cryptography.X509Certificates.X509Certificate2 certificate) [0x00000] in <filename unknown>:0
  --- End of inner exception stack trace ---
  at System.Security.Cryptography.X509Certificates.X509Chain.Build (System.Security.Cryptography.X509Certificates.X509Certificate2 certificate) [0x00000] in <filename unknown>:0
  at System.Net.ServicePointManager+ChainValidationHelper.ValidateChain (Mono.Security.X509.X509CertificateCollection certs) [0x00000] in <filename unknown>:0
Please, report this problem to the Mono team
News: Join the Knuckle Cracker Discord Chat! -> |u=https://discord.gg/knucklecracker Open_Web_Page
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)



Karsten75

  • Hero Member
  • *****
    • Posts: 6833
Reply #5 on: November 05, 2018, 11:34:26 pm
It makes things a lot easier if you'd just put the log file in an attachment.


"Any leftover cabbage can and will be mixed with mayo"
   - Cole's Law


knucracker

  • Administrator
  • *****
    • Posts: 11750
Reply #6 on: November 06, 2018, 01:37:21 pm
How long ago was the game working for you?  Is it something you played months ago then game back recently and it wasn't working, or was it working fine like last week and then it stopped a few days ago?



environerd

  • Jr. Member
  • **
    • Posts: 6
Reply #7 on: November 06, 2018, 03:00:19 pm
Maybe a week at most since I last played, then this started. So yes, it was working fine last week and stopped a few days ago. I attached the log in an attachment like someone else suggested.



knucracker

  • Administrator
  • *****
    • Posts: 11750
Reply #8 on: November 06, 2018, 03:44:30 pm
The exception in the log is basically related to certificate chain verification.  Thing is, I have not changed the https certificate on the server in over 6 months, and the game hasn't changed in that time frame either.  So for it to stop working recently, it seems like something in the middle must have changed.  You mentioned a wifi change earlier.  Are you running behind a web proxy server or anything that might be acting like a man-in-the-middle for an HTTPS connection?



environerd

  • Jr. Member
  • **
    • Posts: 6
Reply #9 on: December 13, 2018, 08:15:12 pm
No proxy server or anything like that. I just updated the OS and am still having the same problem.

Sorry it took so long to reply, I got really busy with my thesis and finals.



knucracker

  • Administrator
  • *****
    • Posts: 11750
Reply #10 on: December 22, 2018, 10:19:03 am
I've not received any other similar reports, and it works on my mac.... so I'm still guessing it must have something to do with your particular network or environment.

One experiment might be to try to launch the game while you are not connected to any network at all.



Karsten75

  • Hero Member
  • *****
    • Posts: 6833
Reply #11 on: December 22, 2018, 12:07:48 pm

"Any leftover cabbage can and will be mixed with mayo"
   - Cole's Law


saas2813

  • Jr. Member
  • **
    • Posts: 8
Reply #12 on: June 09, 2019, 06:49:59 pm
Was there ever any solution to this?

I'm getting the same symptoms.
I bought the game from GamersGate before the Steam version and have played it from time to time since then.
I'm not sure if I have played it since replacing my computer (using the mac feature to copy data from my old computer), probably not since the latest changed file in the ~/Documents/creeperworld3/colonialspace  is august 2017.
I think the game actually "works" except for not showing any graphics, I can hear it reacting to mouse clicks.
Both CW1&2 is playable.
I tried starting an old copy of CW3 version 1 and it behaved similar to v2, I could hear the Knuckle cracker sound but not see anything, but then it crashed and threw up an Apple Crash-reporter.
The Steam version behaves the same both with and without the Steam overlay.
It even managed to report an achievement when I happened to click on the campaign.
I tried the older version linked above with the same behaviour.

When starting the game in windowed mode nothing at all is shown, not even the window borders.
(There is a window border highlighted for a while when selecting "Bring All to Front".)

My previous computer is a MacBook Air from 2011 with OS X 10.10.5
This computer is a MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports) with OS X 10.14.5  And  Intel Iris Plus Graphics 650 1536 MB
I have Paralells installed, but not running on the new computer but not on the old one.
I currently does not have any extra screen connected but frequently uses a Lenovo with USB-C connector.

I tried to launch the game with my WiFi turned off but still got the same result.
I even tried to reboot and upgrade the computer with no luck.



environerd

  • Jr. Member
  • **
    • Posts: 6
Reply #13 on: June 09, 2019, 09:47:26 pm
Unfortunately no, nothing suggested has worked. Iím not sure what the problem is.



knucracker

  • Administrator
  • *****
    • Posts: 11750
Reply #14 on: June 10, 2019, 10:00:23 am
On your mac, go to this directory:
/Users/YOURUSER/.config/creeperworld3
(edited to add s to User)

In there are two xml files.  Rename them (or move them) and then start the game again.  See if that makes any difference.
« Last Edit: June 11, 2019, 08:42:01 pm by knucracker »