Author Topic: Magenta Textures  (Read 165 times)

Skellitor301

  • Newbie
  • *
  • Posts: 2
Magenta Textures
« on: June 10, 2018, 02:48:31 pm »
So I'm not sure what is going on here but I'm getting a broken texture bug. (See attachment)
I've tried searching around for the answer and I did find an old post about the bug and multiple GPU's. Thing is I dont have multiple GPU's, only a GeForce 610, and the game was working just fine before this post. Any help I can get would be greatly appreciated.

Karsten75

  • Hero Member
  • *****
  • Posts: 6499
Re: Magenta Textures
« Reply #1 on: June 10, 2018, 05:43:44 pm »
Firstly let me thank you for actually searching.

The issue is directly to do with a graphics card. You can find numerous hits in many different games if you search on the Internet.

I'm not sure if playing with settings may affect it. If you know of a diagnostic tool, you can try running that. Try, for instance, 3Dmark (https://www.3dmark.com/) and see if your card pass all benchmark tests and perform comparable to other cards of the same type in the benchmark database.

Next time you start up CW3, find the log file and attach it to your post here. We may be able to discern something from that.
"Any leftover cabbage can and will be mixed with mayo"
   - Cole's Law

Skellitor301

  • Newbie
  • *
  • Posts: 2
Re: Magenta Textures
« Reply #2 on: June 12, 2018, 11:38:32 am »
Well, I'm not sure what it was but I was able to fix it by reinstalling the game from Steam. I've tried updating my drivers and messing with it's settings and nothing worked, so I started trying things that wouldn't really have anything to do with it and somehow a fresh install was the answer.

Karsten75

  • Hero Member
  • *****
  • Posts: 6499
Re: Magenta Textures
« Reply #3 on: June 12, 2018, 01:46:27 pm »
Well, I'm glad you're back in the saddle, so to speak. :)
"Any leftover cabbage can and will be mixed with mayo"
   - Cole's Law

NinjaPleez

  • Newbie
  • *
  • Posts: 1
Re: Magenta Textures
« Reply #4 on: June 15, 2018, 03:41:34 am »
I am also experiencing a very similar issue. My textures are far worse off, however. Literally every sprite that isn't a font seems to be missing its shader. I've tried verifying cache, uninstall/reinstall, driver updates/rollbacks, -force-d3d9, d3d11, opengl, etc. Nothing has worked. Any ideas would be appreciated.


Karsten75

  • Hero Member
  • *****
  • Posts: 6499
Re: Magenta Textures
« Reply #5 on: June 15, 2018, 04:07:57 am »
I'd suggest you try running something like Passmark's burn-in test or even the benchmark utility. Then compare your card/system's performance with other similar systems. Might give you a heads-up if you should be looking at that. Do you have any experience on different games that might help you narrow down on the problem? If it's only one game, then you might want to look into other factors.

Also, based on some things you say, are you running on Linux or Windows?

Here's my log, takesn as of right now


However, that gives me an idea. If your processor has integrated graphics, connect your monitor to the graphics output on the backplate of the motherboard and see if that gives a different result.
"Any leftover cabbage can and will be mixed with mayo"
   - Cole's Law