Author Topic: Ship designs won't save  (Read 768 times)

DigUpSkulls

  • Newbie
  • *
  • Posts: 3
Ship designs won't save
« on: February 24, 2018, 08:56:08 pm »
I can't find any help on this. In ship editor when I make a ship it won't save. All I am getting is a white square in the middle of the screen. I've tried pressing the "Create New Ship" button before making a new ship and after making a ship and get the same results each time.

GoodMorning

  • Community Guild
  • *****
  • Posts: 3262
  • (Pusillanimous)
Re: Ship designs won't save
« Reply #1 on: February 24, 2018, 09:08:41 pm »
The most common cause of this is not hitting "apply" before exiting the editor or starting a new ship.

Yes, it is an odd one.

Does that help?
A narrative is a lightly-marked path to another reality.

DigUpSkulls

  • Newbie
  • *
  • Posts: 3
Re: Ship designs won't save
« Reply #2 on: February 24, 2018, 10:10:09 pm »
Apply button never appears in the editor.

GoodMorning

  • Community Guild
  • *****
  • Posts: 3262
  • (Pusillanimous)
Re: Ship designs won't save
« Reply #3 on: February 24, 2018, 10:27:14 pm »
This apply button?

If that doesn't appear, you have larger problems.

Oh, wait...

I cannot test this, but you may need to enter a ship name, hit "create new ship", and then start drawing.
A narrative is a lightly-marked path to another reality.

bluebolt

  • Community Guild
  • *****
  • Posts: 97
  • Eagerly Awaiting 4RPL
Re: Ship designs won't save
« Reply #4 on: February 24, 2018, 10:30:44 pm »
No there has to be a name before it will create a ship, so that won't be the problem
My Custom Stuff here (ARC Custom modules included)

bluebolt

  • Community Guild
  • *****
  • Posts: 97
  • Eagerly Awaiting 4RPL
Re: Ship designs won't save
« Reply #5 on: February 24, 2018, 10:36:28 pm »
The white square you are talking about surrounds the Command Module right? That's actually basic hull. Press 'EDIT HULL'(top right) to paint hull, and armor. And to make sure the ship is being properly created, the make 2 with the same name. The second shouldn't create because the first one exists. Not entirely sure what else your problem could be without more information :l
My Custom Stuff here (ARC Custom modules included)

Sorrontis

  • Community Guild
  • *****
  • Posts: 1939
  • CW4! CW4! CW4! CW4! CW4!
    • Sorrontis Games
Re: Ship designs won't save
« Reply #6 on: February 24, 2018, 11:07:04 pm »
Hello DigUp.

Can you provide us with a sreenshot of the game when you first create a ship?

Is it possible you mistakenly deleted the Command Module? It sounds like there's no Command Module.

Also, did you potentially erase some of the hull from under any of the modules? If you place any module, and mistakenly erase a square of hull under it, the module will turn red and you will not be able to save the ship.

Are you sure that all the hull is connected? You should get an error message that says that some of the hull is not connected. This will prevent you from saving the ship.

Also, if none of those are the problem, I'm going to need you to give me a debug file (https://knucklecracker.com/forums/index.php?topic=21330.0).

But first, a screen shot.


Also, is this your first time running the game? Did you previously make ships and now it doesn't work anymore - or has it never worked?

If this is the first time you tried to run the game and make a ship, you could have a bad install - or a corrupt file. Restart your computer (and if on steam, check file integrity). You might have to reinstall the game.
« Last Edit: February 24, 2018, 11:10:25 pm by Sorrontis »
"If you want others to be happy, practice compassion. If you want to be happy, practice compassion."

DigUpSkulls

  • Newbie
  • *
  • Posts: 3
Re: Ship designs won't save
« Reply #7 on: February 25, 2018, 10:54:14 am »
Command module is still there, Names are there. No matter how many times I edit the ship the apply button at the bottom of the screen never appears. I have uninstalled and reinstalled the game. I haven't gotten any error messages.  I have tried pressing the Create New Ship button before and after making a ship all with the same result.
« Last Edit: February 25, 2018, 10:57:52 am by DigUpSkulls »

FOXX

  • Community Guild
  • *****
  • Posts: 1020
  • Just Breathe
Re: Ship designs won't save
« Reply #8 on: February 25, 2018, 10:55:48 am »
Hi DigUpSkulls,

After you press Create new Ship you have to click on the Ships name in the list before you can save your progress.
If you press Create new Ship and immediately start editing then the Apply Button doesn't show up.

Greets
FOXX
The FPAF
For My Maps and Ships!
Including  CUSTOM MODULE MAPS & SHIPS