Author Topic: CW game resetted itself  (Read 122 times)

cvtfwlbt

  • Newbie
  • *
  • Posts: 23
CW game resetted itself
« on: October 04, 2017, 06:51:36 pm »
Hello, long time no see. I've been playing play CW 1 mostly lately, a couple of times a day, and this afternoon, suddenly, I reopened the game and it looked like it had resetted itself. No recorded Story missions, no Hall of Honor; Conquest, Special Ops, Chronom locked. Only thing I can play are the Custom maps (also here, no in-game recorded plays or scores, just the maps showing up) and Story from the beginnig. I tried replaying a short Custom map, and my new score - submitted with my usual player name- was not recorded online. I had 2 plays before, and I had not 3 plays after, not even my player name showing up twice. But then I played a new map, and there it is my name right there. I also tried deleting an old map, and reimporting, but to no avail, the new score won't show, only on Custom maps that I've never played before. Same with Story, scores won't show online. CW 2 and 3 seem to work fine, I had a look at CW folders but well, I don't get much of that stuff. If it could be useful, my GameData.dat file shows 16kb. Any idea? I also tried installing the latest patch, anniversary Vers 800 but nothing changed. I'm now back to Vers. 572. Running on Windows 10. I updated Air no more than two weeks ago. Thanks for any suggestion!
« Last Edit: October 04, 2017, 06:54:14 pm by cvtfwlbt »

virgilw

  • Administrator
  • *****
  • Posts: 11656
Re: CW game resetted itself
« Reply #1 on: October 05, 2017, 09:15:58 am »
All of your progress is stored in gameData.dat.  I'd do a reboot of your machine (a full shutdown and restart) to make sure no files are locked (like the gameData.dat file).  If you have a backup of gameData.dat you could also try restoring that (make a copy of your current gameData.dat first so you can put it back if necessary).

cvtfwlbt

  • Newbie
  • *
  • Posts: 23
Re: CW game resetted itself
« Reply #2 on: October 05, 2017, 12:10:27 pm »
Thanks for the suggestions! So I rebooted the PC, even after last night's stop, but that didn't solve the issue. But I remembered that I actually still do have my old PC with the game on, so I brought it back to life, checked that everything was running fine, and moved the old gameData file to the new PC. Turns out that the dimensions were different, on the old PC it was almost twice the size, so the file on the new PC somehow got corrupted out of nowhere, can't imagine how... I verified that I can again post scores, so everything is fine now. Thanks again!