[BUG?] Ships with reactors and ports wont refill seperate ships with empty tanks

Three_Pryme · 541

Three_Pryme

  • Jr. Member
  • **
    • Posts: 57
  • Hello
Im using no energy sources and no energy pods. Just ships with reactors when I noticed the ship with reactors built the ship with tanks completely but refused to fill up the tanks

Commanding officer in particle extermination

Steam ID:Three_Pryme


GoodMorning

  • Community Guild
  • *****
    • Posts: 3412
  • (Pusillanimous)
Power movement seems to be calculated as absolute power-on-hand for each ship, rather than proportion-of-full. So both ships will have 50 power, I think it is, stored in the bridge, and the reactor vessel knows that it has exactly as much power as the tanker. So, it doesn't transfer.

This is to ensure that a Tanker doesn't wait for a ship to become depleted to 50% of power before resupplying it, potentially wasting time.

Perhaps we need a 'fill'/'auto' mode for tanks, where they drain power until completely full, and then return to normal behaviour.

A narrative is a lightly-marked path to another reality.


Karsten75

  • Hero Member
  • *****
    • Posts: 6907
As an experiment, try putting 1 tank on the reactor ship?

'If you want to live a happy life, tie it to a goal, not to people or things.'

Albert Einstein
(1879-1955)


Three_Pryme

  • Jr. Member
  • **
    • Posts: 57
  • Hello
ive noticed this, Ive  put a ship with 4 tanks and like 30 missiles and 10 cannons. But the tanks on that ship fill all the way! Im not sure whats causing this. Maybe more power for weaponry?

Commanding officer in particle extermination

Steam ID:Three_Pryme


Three_Pryme

  • Jr. Member
  • **
    • Posts: 57
  • Hello
This is the ship


Commanding officer in particle extermination

Steam ID:Three_Pryme