[Bug] Game starts on wrong screen (Windows 7, Multi-Monitor)

alfanugan · 417

alfanugan

  • Jr. Member
  • **
    • Posts: 21
I have two monitors:
Monitor 1 (left side): 2560x1440
Monitor 2 (right side): (Primary) 1920x1080
Video Card: GTX 760 (latest drivers)

When I set the game, in windowed mode on monitor 1 with it maximized for the screen, as you can see in PF_Settings.jpg, everything looks good.  I can hit Apply and everything is as expected.  If I close the game, then relaunch, it starts with the same resolution but on monitor 2.  The settings menu option is almost cut off and the entire top is cut off as seen in PF_Settings_reloaded.jpg.  The black at the top of the reloaded screenshot was generated by Windows, but cannot actually be seen on the screen.

Luckily the game loads in windowed mode so i can stretch it over to monitor 1, then grab the window and move it, but I need to do this every time I launch the game.

Please let me know if I am doing something wrong here!

/\lways (oca(ola


Karsten75

  • Hero Member
  • *****
    • Posts: 6834
Reply #1 on: October 08, 2016, 11:16:30 am
It's a Unity "feature". Try having the window a few pixels smaller than the monitor. That's what I do and it works just fine.

Happens in all the Unity games I play, not just Particle Fleet. 

"Any leftover cabbage can and will be mixed with mayo"
   - Cole's Law


knucracker

  • Administrator
  • *****
    • Posts: 11750
Reply #2 on: October 08, 2016, 11:31:36 am
Try fiddling with the monitor settings on the graphics menu.  The numbering there can be backwards from what you think.  Note that after changing that setting you have to exit the game and restart it.  Do that twice actually, since the monitor anchor settings have to be written, read, and written again (it's a crazy I know).  YOu might get different results when setting it to default, 1, or 2.