Linux and OS X users

knucracker · 7596

Ge0rgecz

  • Newbie
  • *
    • Posts: 4
Reply #45 on: October 18, 2016, 02:36:55 pm
Thank you.

BTW, my Ubuntu default language is Czech (cs_CZ).

This bug is not only about DEMO version, same thing happens in "STEAM version" too (bought right now).
Temporary solution in STEAM:
1. right click on downloaded game in library
2. select "Properties" (last row) in context menu
3. SET LAUNCH OPTIONS... button (first button on first tab)
4. and type: LC_ALL=C %command%
5. confirm with OK button

Btw, its awesome game, masterpiece no.2. Worth the money.
« Last Edit: October 18, 2016, 03:19:19 pm by Ge0rgecz »



toolforger

  • Full Member
  • ***
    • Posts: 152
Reply #46 on: June 30, 2017, 11:41:02 am
The game doesn't install properly from Steam for me.
I can start it just fine from the Steam client, but the installer has trouble putting it into the desktop's start menu, and when I tried to do that manually it failed with some permission problem (but it didn't clearly say what it was trying to do so so I don't know what permission is wrong, or whether it tried to install a system-wide entry where it should have been a user-specific one).

This is on Ubuntu 16.04.2 LTS.
Steam version is 1:1.0.0.48-1ubuntu4

Arc Eternal installed fine, btw, so I assume it's either a difference in the installers between Arc Eternal and Particle Fleet, or some permission changes done by an Ubuntu or Steam update (I didn't change permissions manually).

Also, I don't see a way to send ratings. This might or might not be related, I have no clue.
UPDATE: Taking this to http://knucklecracker.com/forums/index.php?topic=21626.0 as it's unrelated.
« Last Edit: June 30, 2017, 11:43:40 am by toolforger »



knucracker

  • Administrator
  • *****
    • Posts: 11749
Reply #47 on: July 25, 2017, 12:05:43 pm
The current beta branch of the game allows rating a map at the end of the mission (rather than on the selection menu only).

As for installing, the steam client does all of that. I don't have an installer I wrote for the game when it is installed by steam. There are just the game files and the steam client puts them where it wants and then creates icons (or not) as it sees fit.  So I can't help with direct installation issues other than to say to do the normal things (reboot, make sure you are running the steam client with an user that has adequate permissions).

If the problem persists and nothing shakes loose, you can email me at support@knucklecracker.com.