Bug report (kind of, at least)

12345ieee · 1069

12345ieee

  • Jr. Member
  • **
    • Posts: 65
on: February 07, 2014, 07:22:35 pm
I don't know if these are really bugs, but I'm pretty sure they are not the behaviour I'd want for these things:

1) As noted in this topic the behaviour of the slip emitters in Egos:Ruine changed from a cool C/AC annihilation in 1.04 to a (quite ugly, imho) splash of creeper in the void in 1.79.
I could track exactly in which version the change happened, but I'm pretty sure Virgil can do it faster and more reliably than me

2) When a guppy dies from damage, if the pad is intact, it gets rebuilt automatically, very useful feature.
The problem is that the guppy gets automatically rebuilt as "packet guppy", even if when it got destroyed it was an ore/AC guppy.
I find this slightly annoying, but there may be a reason behind it.

I'm using the up-to-date v1.79, 64 bit Windows version, the 1st issue is also confirmed by the other two post in the linked topic.

Hope it helps.

12345ieee



knucracker

  • Administrator
  • *****
    • Posts: 11749
Reply #1 on: February 07, 2014, 07:39:06 pm
Whoops.... big whoops :)
Ruine isn't supposed to be like that.  The problem isn't in the mission, it is with a bug I introduced when I added paused core operation support.  Ruine uses the InvocationCount CRPL api (probably the only map to do so) and sets the fields in the first invocation.  But this got broken so the invocation count is higher than 1 when the map starts, so the fields never get set.

So this mission is a little harder than before because of this.  I think it can still be won, but I'll roll out an update that fixes this issue.



deety42

  • Full Member
  • ***
    • Posts: 156
Reply #2 on: February 14, 2014, 10:30:45 pm
Thanks, Virgil!  I was just going back and attempting speed runs for the story missions and couldn't see how to get close on Ruine.  I finally broke down and went to look at at one of Fisherck's videos of a speed run and thought, gee...that looks much easier.  I guess I'll skip this one for now, but it definitely is possible...



Michionlion

  • Sr. Member
  • ****
    • Posts: 1933
  • The Reclaimer
Reply #3 on: February 14, 2014, 10:42:23 pm
The recent beta build on the forums, (and the current public one, I think) fixed the bug that V talked about.

"Remember kids, the only difference between science and messing around is writing it down."
                                                                                                                         - Adam Savage

My website
My CW1, and CW2 maps!